Tunnel Activity
tunnel_activity
Tunnel Activity events report secure tunnel establishment (such as VPN), teardowns, renewals, and other network tunnel specific actions.
Attributes
| Caption | Name | Type | Description |
|---|---|---|---|
| Action | action | String | Group:primaryThe normalized caption of action_id. |
| Action ID | action_id | Integer | Group:primaryThe action taken by a control or other policy-based system leading to an outcome or disposition. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
|
| Activity ID | activity_id | Integer | Group:classificationThe normalized identifier of the activity that triggered the event.
|
| Activity | activity_name | String | Group:classificationThe event activity name, as defined by the activity_id. |
| Actor | actor | Actor[] | Group:primaryThe actor object describes details about the user/role/process that was the source of the activity. Note that this is not the threat actor of a campaign but may be part of a campaign. |
| API Details | api | API[] | Group:contextDescribes details about a typical API (Application Programming Interface) call. |
| Application Name | app_name | String | Group:contextThe name of the application associated with the event or object. |
| MITRE ATT&CK® and ATLAS™ Details | attacks | MITRE ATT&CK® & ATLAS™[] | Group:primaryAn array of MITRE ATT&CK® objects describing identified tactics, techniques & sub-techniques. The objects are compatible with MITRE ATLAS™ tactics, techniques & sub-techniques. |
| Authorization Information | authorizations | Authorization Result[] | Group:primaryProvides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event. |
| Category | category_name | String | Group:classificationThe event category name, as defined by category_uid value: Network Activity. |
| Category ID | category_uid | Integer | Group:classificationThe category unique identifier of the event.
|
| Class | class_name | String | Group:classificationThe event class name, as defined by class_uid value: Tunnel Activity. |
| Class ID | class_uid | Integer | Group:classificationThe unique identifier of a class. A class describes the attributes available in an event.
|
| Cloud | cloud | Cloud[] | Group:primaryDescribes details about the Cloud environment where the event was originally created or logged. |
| Confidence | confidence | String | Group:primaryThe confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source. |
| Confidence ID | confidence_id | Integer | Group:primaryThe normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
|
| Confidence Score | confidence_score | Integer | Group:primaryThe confidence score as reported by the event source. |
| Connection Info | connection_info | Network Connection Information[] | Group:contextThe tunnel connection information. |
| Count | count | Integer | Group:occurrenceThe number of times that events in the same logical group occurred during the event Start Time to End Time period. |
| Device | device | Device[] | Entity:ENDPOINTGroup: primaryThe device that reported the event. |
| Disposition | disposition | String | Group:primaryThe disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source. |
| Disposition ID | disposition_id | Integer | Group:primaryDescribes the outcome or action taken by a security control, such as access control checks, malware detections or various types of policy violations.
|
| Destination Endpoint | dst_endpoint | Network Endpoint[] | Entity:ENDPOINTGroup: primaryThe server responding to the tunnel connection. |
| Duration Milliseconds | duration | Long | Group:occurrenceThe event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds. |
| End Time | end_time | Timestamp | Group:occurrenceThe end time of a time period, or the time of the most recent event included in the aggregate event. |
| Enrichments | enrichments | Enrichment[] | Group:contextThe additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:["name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": "city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"] |
| Firewall Rule | firewall_rule | Firewall Rule[] | Group:primaryThe firewall rule that pertains to the control that triggered the event, if applicable. |
| Alert | is_alert | Boolean | Group:primaryIndicates that the event is considered to be an alertable signal. Should be set to true if disposition_id = Alert among other dispositions, and/or risk_level_id or severity_id of the event is elevated. Not all control events will be alertable, for example if disposition_id = Exonerated or disposition_id = Allowed. |
| JA4+ Fingerprints | ja4_fingerprint_list | JA4+ Fingerprint[] | Group:contextA list of the JA4+ network fingerprints. |
| Load Balancer | load_balancer | Load Balancer[] | Group:primaryThe Load Balancer object contains information related to the device that is distributing incoming traffic to specified destinations. |
| Malware | malware | Malware[] | Group:primaryA list of Malware objects, describing details about the identified malware. |
| Malware Scan Info | malware_scan_info | Malware Scan Info[] | Group:primaryDescribes details about the scan job that identified malware on the target system. |
| Message | message | String | Group:primaryThe description of the event/finding, as defined by the source. |
| Metadata | metadata | Metadata[] | Group:contextThe metadata associated with the event or a finding. |
| Observables | observables | Observable[] | Group:primaryThe observables associated with the event or a finding. |
| OSINT | osint | OSINT[] | Group:primaryThe OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers. |
| Policy | policy | Policy[] | Group:primaryThe policy that pertains to the control that triggered the event, if applicable. For example the name of an anti-malware policy or an access control policy. |
| Tunnel Protocol | protocol_name | String | Group:contextThe networking protocol associated with the tunnel. E.g. IPSec, SSL, GRE. |
| Proxy | proxy | Network Proxy Endpoint[] | Entity:ENDPOINTGroup: primaryThe proxy (server) in a network connection.
|
| Proxy Connection Info | proxy_connection_info | Network Connection Information[] | Group:contextThe connection information from the proxy server to the remote server. |
| Proxy Endpoint | proxy_endpoint | Network Proxy Endpoint[] | Entity:ENDPOINTGroup: contextThe proxy (server) in a network connection. |
| Proxy HTTP Request | proxy_http_request | HTTP Request[] | Group:contextThe HTTP Request from the proxy server to the remote server. |
| Proxy HTTP Response | proxy_http_response | HTTP Response[] | Group:contextThe HTTP Response from the remote server to the proxy server. |
| Proxy TLS | proxy_tls | Transport Layer Security (TLS)[] | Group:contextThe TLS protocol negotiated between the proxy server and the remote server. |
| Proxy Traffic | proxy_traffic | Network Traffic[] | Group:contextThe network traffic refers to the amount of data moving across a network, from proxy to remote server at a given point of time. |
| Raw Data | raw_data | JSON | Group:contextThe event data as received from the event source. |
| Raw Data Hash | raw_data_hash | Fingerprint[] | Entity:FINGERPRINTGroup: contextThe hash, which describes the content of the raw_data field. |
| Raw Data Size | raw_data_size | Long | Group:contextThe size of the raw data which was transformed into an OCSF event, in bytes. |
| Record ID | record_id | String | Group:primaryUnique idenifier for the event |
| Risk Details | risk_details | String | Group:primaryDescribes the risk associated with the finding. |
| Risk Level | risk_level | String | Group:primaryThe risk level, normalized to the caption of the risk_level_id value. |
| Risk Level ID | risk_level_id | Integer | Group:primaryThe normalized risk level id.
|
| Risk Score | risk_score | Integer | Group:primaryThe risk score as reported by the event source. |
| Tunnel Session | session | Session[] | Group:primaryThe session associated with the tunnel. |
| Severity | severity | String | Group:classificationThe event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source. |
| Severity ID | severity_id | Integer | Group:classificationThe normalized identifier of the event/finding severity.The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
|
| Source Endpoint | src_endpoint | Network Endpoint[] | Entity:ENDPOINTGroup: primaryThe initiator (client) of the tunnel connection. |
| Start Time | start_time | Timestamp | Group:occurrenceThe start time of a time period, or the time of the least recent event included in the aggregate event. |
| Status | status | String | Group:primaryThe event status, normalized to the caption of the status_id value. In the case of 'Other', it is defined by the event source. |
| Status Code | status_code | String | Group:primaryThe event status code, as reported by the event source.For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18. |
| Status Detail | status_detail | String | Group:primaryThe status detail contains additional information about the event/finding outcome. |
| Status ID | status_id | Integer | Group:primaryThe normalized identifier of the event status.
|
| Event Time | time | Timestamp | Group:occurrenceThe normalized event occurrence time or the finding creation time. |
| Timezone Offset | timezone_offset | Integer | Group:occurrenceThe number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080. |
| TLS | tls | Transport Layer Security (TLS)[] | Group:contextThe Transport Layer Security (TLS) attributes. |
| Traffic | traffic | Network Traffic[] | Group:contextTraffic refers to the amount of data moving across the tunnel at a given point of time. Ex: bytes_in and bytes_out. |
| Tunnel Interface | tunnel_interface | Network Interface[] | Group:primaryThe information about the virtual tunnel interface, e.g. utun0. This is usually associated with the private (rfc-1918) ip of the tunnel. |
| Type | tunnel_type | String | Group:primaryThe tunnel type. Example: Split or Full. |
| Type | tunnel_type_id | Integer | Group:primaryThe normalized tunnel type ID.
|
| Type Name | type_name | String | Group:classificationThe event/finding type name, as defined by the type_uid. |
| Type ID | type_uid | Long | Group:classificationThe event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
|
| Unmapped | unmapped | Unmapped[] | Group:contextData from the source that was not mapped into the schema. |
| User | user | User[] | Entity:USERGroup: primaryThe user associated with the tunnel activity. |
Relationships
Outbound Relationships
Tunnel Activity references the following objects and events in its attributes:
- User
- Transport Layer Security (TLS)
- OSINT
- Network Traffic
- Network Interface
- API
- Load Balancer
- Network Proxy Endpoint
- Unmapped
- Observable
- HTTP Response
- MITRE ATT&CK® & ATLAS™
- Enrichment
- Network Endpoint
- Policy
- Network Connection Information
- Fingerprint
- Firewall Rule
- HTTP Request
- Authorization Result
- Metadata
- JA4+ Fingerprint
- Malware Scan Info
- Actor
- Session
- Device
- Cloud
- Malware
This page describes qdm-1.5.1+ocsf-1.6.0