Security Finding

security_finding

🚧 WARNING: DEPRECATED Security Finding has been deprecated since 1.4.0. Deprecated in QDM 1.4.0
Security Finding events describe findings, detections, anomalies, alerts and/or actions performed by security products

Attributes

CaptionNameTypeDescription
ActionactionStringGroup:primary

The normalized caption of action_id.
Action IDaction_idIntegerGroup:primary

The action taken by a control or other policy-based system leading to an outcome or disposition. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
  • 0: Unknown (UNKNOWN)
  • 1: Allowed (ALLOWED)
  • 2: Denied (DENIED)
  • 3: Observed (OBSERVED)
  • 4: Modified (MODIFIED)
  • 99: Other (OTHER)
Activity IDactivity_idIntegerGroup:classification

The normalized identifier of the activity that triggered the event.
  • 1: Create (CREATE)
  • 2: Update (UPDATE)
  • 3: Close (CLOSE)
  • 0: Unknown (UNKNOWN)
  • 99: Other (OTHER)
Activityactivity_nameStringGroup:classification

The event activity name, as defined by the activity_id.
ActoractorActor[]Group:primary

The actor object describes details about the user/role/process that was the source of the activity. Note that this is not the threat actor of a campaign but may be part of a campaign.
AnalyticanalyticAnalytic[]Group:primary

The analytic technique used to analyze and derive insights from the data or information that led to the finding or conclusion.
API DetailsapiAPI[]Group:context

Describes details about a typical API (Application Programming Interface) call.
MITRE ATT&CK® and ATLAS™ DetailsattacksMITRE ATT&CK® & ATLAS™[]Group:context

An array of MITRE ATT&CK® objects describing the tactics, techniques & sub-techniques associated to the Finding.
Authorization InformationauthorizationsAuthorization Result[]Group:primary

Provides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event.
Categorycategory_nameStringGroup:classification

The event category name, as defined by category_uid value: Findings.
Category IDcategory_uidIntegerGroup:classification

The category unique identifier of the event.
  • 2: Findings (FINDINGS)
CIS CSCcis_cscCIS CSC[]Group:context

The CIS Critical Security Controls is a list of top 20 actions and practices an organization’s security team can take on such that cyber attacks or malware, are minimized and prevented.

🚧 WARNING: DEPRECATED

CIS CSC has been deprecated since 1.5.0. Use CIS Controls for standard benchmark controls.

Classclass_nameStringGroup:classification

The event class name, as defined by class_uid value: Security Finding.
Class IDclass_uidIntegerGroup:classification

The unique identifier of a class. A class describes the attributes available in an event.
  • 2001: Security Finding (SECURITY_FINDING)
CloudcloudCloud[]Group:primary

Describes details about the Cloud environment where the event was originally created or logged.
CompliancecomplianceCompliance[]Group:context

The compliance object provides context to compliance findings (e.g., a check against a specific regulatory or best practice framework such as CIS, NIST etc.) and contains compliance related details.
ConfidenceconfidenceIntegerGroup:classification

The confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source.
Confidence IDconfidence_idIntegerGroup:primary

The normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
  • 0: Unknown (UNKNOWN)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 99: Other (OTHER)
Confidence Scoreconfidence_scoreIntegerGroup:primary

The confidence score as reported by the event source.
CountcountIntegerGroup:occurrence

The number of times that events in the same logical group occurred during the event Start Time to End Time period.
DatadataJSONThe additional data that is associated with the event or object. See specific usage.
Data Sourcesdata_sourcesString[]Group:context

A list of data sources utilized in generation of the finding.
DevicedeviceDevice[]Entity:ENDPOINT
Group:primary

An addressable device, computer system or host.
DispositiondispositionStringGroup:primary

The disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source.
Disposition IDdisposition_idIntegerGroup:primary

When security issues, such as malware or policy violations, are detected and possibly corrected, then disposition_id describes the action taken by the security product.
  • -1: Other (OTHER)
  • 0: Unknown (UNKNOWN)
  • 1: Blocked (BLOCKED)
  • 2: Allowed (ALLOWED)
  • 3: No Action (NO_ACTION)
  • 4: Logged (LOGGED)
  • 5: Command Script Run (COMMAND_SCRIPT_RUN)
  • 6: Corrected (CORRECTED)
  • 7: Partially Corrected (PARTIALLY_CORRECTED)
  • 8: Uncorrected (UNCORRECTED)
  • 10: Delayed (DELAYED)
  • 11: Detected (DETECTED)
  • 12: Quarantined (QUARANTINED)
  • 13: Restored (RESTORED)
  • 14: Exonerated (EXONERATED)
  • 15: Tagged (TAGGED)
  • 9: Restored (RESTORED)
  • 16: No Action (NO_ACTION)
  • 17: Logged (LOGGED)
  • 18: Tagged (TAGGED)
  • 19: Alert (ALERT)
  • 20: Count (COUNT)
  • 21: Reset (RESET)
  • 22: Captcha (CAPTCHA)
  • 23: Challenge (CHALLENGE)
  • 24: Access Revoked (ACCESS_REVOKED)
  • 25: Rejected (REJECTED)
  • 26: Unauthorized (UNAUTHORIZED)
  • 27: Error (ERROR)
  • 99: Other (OTHER)
DurationdurationLongGroup:occurrence

The event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds.
End Timeend_timeTimestampGroup:occurrence

The end time of a time period, or the time of the most recent event included in the aggregate event.
EnrichmentsenrichmentsEnrichment[]Group:context

The additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:["name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": "city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"]
EvidenceevidenceJSONGroup:context

The data the finding exposes to the analyst.

🚧 WARNING: DEPRECATED

Evidence has been deprecated since 1.1.0. Use the evidences attribute instead.

FindingfindingFinding[]Group:primary

The Finding object provides details about a finding/detection generated by a security tool.
Firewall Rulefirewall_ruleFirewall Rule[]Group:primary

The firewall rule that pertains to the control that triggered the event, if applicable.
ImpactimpactStringGroup:primary

The impact , normalized to the caption of the impact_id value. In the case of 'Other', it is defined by the event source.
Impact IDimpact_idIntegerGroup:primary

The normalized impact of the incident or finding. Per NIST, this is the magnitude of harm that can be expected to result from the consequences of unauthorized disclosure, modification, destruction, or loss of information or information system availability.
  • 0: Unknown (UNKNOWN)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 4: Critical (CRITICAL)
  • 99: Other (OTHER)
Impact Scoreimpact_scoreIntegerGroup:primary

The impact as an integer value of the finding, valid range 0-100.
Alertis_alertBooleanGroup:primary

Indicates that the event is considered to be an alertable signal. Should be set to true if disposition_id = Alert among other dispositions, and/or risk_level_id or severity_id of the event is elevated. Not all control events will be alertable, for example if disposition_id = Exonerated or disposition_id = Allowed.
Kill Chainkill_chainKill Chain Phase[]Group:context

The Cyber Kill Chain® provides a detailed description of each phase and its associated activities within the broader context of a cyber attack.
MalwaremalwareMalware[]Group:context

A list of Malware objects, describing details about the identified malware.
Malware Scan Infomalware_scan_infoMalware Scan Info[]Group:primary

Describes details about the scan job that identified malware on the target system.
MessagemessageStringGroup:primary

The description of the event/finding, as defined by the source.
MetadatametadataMetadata[]Group:context

The metadata associated with the event or a finding.
NIST ListnistString[]Group:context

The NIST Cybersecurity Framework recommendations for managing the cybersecurity risk.
ObservablesobservablesObservable[]Group:primary

The observables associated with the event or a finding.
OSINTosintOSINT[]Group:primary

The OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers.
PolicypolicyPolicy[]Group:primary

The policy that pertains to the control that triggered the event, if applicable. For example the name of an anti-malware policy or an access control policy.
ProcessprocessLinux Process[]Entity:LINUX_PROCESS
Group:context

The process object.
Raw Dataraw_dataJSONGroup:context

The event data as received from the event source.
Raw Data Hashraw_data_hashFingerprint[]Entity:FINGERPRINT
Group:context

The hash, which describes the content of the raw_data field.
Raw Data Sizeraw_data_sizeLongGroup:context

The size of the raw data which was transformed into an OCSF event, in bytes.
Record IDrecord_idStringGroup:primary

Unique idenifier for the event
Resources ArrayresourcesResource[]Group:primary

A list of resources associated to an event.
Risk Detailsrisk_detailsStringGroup:primary

Describes the risk associated with the finding.
Risk Levelrisk_levelStringGroup:primary

The risk level, normalized to the caption of the risk_level_id value.
Risk Level IDrisk_level_idIntegerGroup:primary

The normalized risk level id.
  • 0: Info (INFO)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 4: Critical (CRITICAL)
  • 99: Other (OTHER)
Risk Scorerisk_scoreIntegerGroup:primary

The risk score as reported by the event source.
SeverityseverityStringGroup:classification

The event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source.
Severity IDseverity_idIntegerGroup:classification

The normalized identifier of the event/finding severity.The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
  • 0: Unknown (UNKNOWN)
  • 1: Informational (INFORMATIONAL)
  • 2: Low (LOW)
  • 3: Medium (MEDIUM)
  • 4: High (HIGH)
  • 5: Critical (CRITICAL)
  • 6: Fatal (FATAL)
  • 99: Other (OTHER)
Start Timestart_timeTimestampGroup:occurrence

The start time of a time period, or the time of the least recent event included in the aggregate event.
StatestateStringGroup:context

The normalized state of a security finding.
State IDstate_idIntegerGroup:context

The normalized state identifier of a security finding.
  • 1: New (NEW)
  • 2: In Progress (IN_PROGRESS)
  • 3: Suppressed (SUPPRESSED)
  • 4: Resolved (RESOLVED)
  • 0: Unknown (UNKNOWN)
  • 99: Other (OTHER)
StatusstatusStringGroup:primary

The event status, normalized to the caption of the status_id value. In the case of 'Other', it is defined by the event source.
Status Codestatus_codeStringGroup:primary

The event status code, as reported by the event source.For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18.
Status Detailsstatus_detailStringGroup:primary

The status detail contains additional information about the event/finding outcome.
Status IDstatus_idIntegerGroup:primary

The normalized identifier of the event status.
  • 0: Unknown (UNKNOWN)
  • 1: Success (SUCCESS)
  • 2: Failure (FAILURE)
  • 99: Other (OTHER)
Event TimetimeTimestampGroup:occurrence

The normalized event occurrence time or the finding creation time.
Timezone Offsettimezone_offsetIntegerGroup:occurrence

The number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080.
Type Nametype_nameStringGroup:classification

The event/finding type name, as defined by the type_uid.
Type IDtype_uidLongGroup:classification

The event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
  • 200101: Security Finding: Create (SECURITY_FINDING_CREATE)
  • 200102: Security Finding: Update (SECURITY_FINDING_UPDATE)
  • 200103: Security Finding: Close (SECURITY_FINDING_CLOSE)
  • 200100: Security Finding: Unknown (SECURITY_FINDING_UNKNOWN)
  • 200199: Security Finding: Other (SECURITY_FINDING_OTHER)
UnmappedunmappedUnmapped[]Group:context

Data from the source that was not mapped into the schema.
VulnerabilitiesvulnerabilitiesVulnerability Details[]Group:context

This object describes vulnerabilities reported in a security finding.

Relationships

Security Finding shown in context

Outbound Relationships

Security Finding references the following objects and events in its attributes:

This page describes qdm-1.5.1+ocsf-1.6.0