NTP Activity

ntp_activity

The Network Time Protocol (NTP) Activity events report instances of remote clients synchronizing their clocks with an NTP server, as observed on the network.

Attributes

CaptionNameTypeDescription
ActionactionStringGroup:primary

The normalized caption of action_id.
Action IDaction_idIntegerGroup:primary

The action taken by a control or other policy-based system leading to an outcome or disposition. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
  • 0: Unknown (UNKNOWN)
  • 1: Allowed (ALLOWED)
  • 2: Denied (DENIED)
  • 3: Observed (OBSERVED)
  • 4: Modified (MODIFIED)
  • 99: Other (OTHER)
Activity IDactivity_idIntegerGroup:classification

The normalized identifier of the activity that triggered the event.
  • 0: Unknown (UNKNOWN)
  • 1: Symmetric Active Exchange (SYMMETRIC_ACTIVE_EXCHANGE)
  • 2: Symmetric Passive Response (SYMMETRIC_PASSIVE_RESPONSE)
  • 3: Client Synchronization (CLIENT_SYNCHRONIZATION)
  • 4: Server Response (SERVER_RESPONSE)
  • 5: Broadcast (BROADCAST)
  • 6: Control (CONTROL)
  • 7: Private Use Case (PRIVATE_USE_CASE)
  • 99: Other (OTHER)
Activityactivity_nameStringGroup:classification

The event activity name, as defined by the activity_id.
ActoractorActor[]Group:primary

The actor object describes details about the user/role/process that was the source of the activity. Note that this is not the threat actor of a campaign but may be part of a campaign.
API DetailsapiAPI[]Group:context

Describes details about a typical API (Application Programming Interface) call.
Application Nameapp_nameStringGroup:context

The name of the application associated with the event or object.
MITRE ATT&CK® and ATLAS™ DetailsattacksMITRE ATT&CK® & ATLAS™[]Group:primary

An array of MITRE ATT&CK® objects describing identified tactics, techniques & sub-techniques. The objects are compatible with MITRE ATLAS™ tactics, techniques & sub-techniques.
Authorization InformationauthorizationsAuthorization Result[]Group:primary

Provides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event.
Categorycategory_nameStringGroup:classification

The event category name, as defined by category_uid value: Network Activity.
Category IDcategory_uidIntegerGroup:classification

The category unique identifier of the event.
  • 4: Network Activity (NETWORK_ACTIVITY)
Classclass_nameStringGroup:classification

The event class name, as defined by class_uid value: NTP Activity.
Class IDclass_uidIntegerGroup:classification

The unique identifier of a class. A class describes the attributes available in an event.
  • 4013: NTP Activity (NTP_ACTIVITY)
CloudcloudCloud[]Group:primary

Describes details about the Cloud environment where the event was originally created or logged.
ConfidenceconfidenceStringGroup:primary

The confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source.
Confidence IDconfidence_idIntegerGroup:primary

The normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
  • 0: Unknown (UNKNOWN)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 99: Other (OTHER)
Confidence Scoreconfidence_scoreIntegerGroup:primary

The confidence score as reported by the event source.
Connection Infoconnection_infoNetwork Connection Information[]Group:primary

The network connection information.
CountcountIntegerGroup:occurrence

The number of times that events in the same logical group occurred during the event Start Time to End Time period.
Root DelaydelayIntegerGroup:primary

The total round-trip delay to the reference clock in milliseconds.
DevicedeviceDevice[]Entity:ENDPOINT
Group:primary

An addressable device, computer system or host.
Root DispersiondispersionIntegerGroup:primary

The dispersion in the NTP protocol is the estimated time error or uncertainty relative to the reference clock in milliseconds.
DispositiondispositionStringGroup:primary

The disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source.
Disposition IDdisposition_idIntegerGroup:primary

Describes the outcome or action taken by a security control, such as access control checks, malware detections or various types of policy violations.
  • 0: Unknown (UNKNOWN)
  • 1: Allowed (ALLOWED)
  • 2: Blocked (BLOCKED)
  • 3: Quarantined (QUARANTINED)
  • 4: Isolated (ISOLATED)
  • 5: Deleted (DELETED)
  • 6: Dropped (DROPPED)
  • 7: Custom Action (CUSTOM_ACTION)
  • 8: Approved (APPROVED)
  • 9: Restored (RESTORED)
  • 10: Exonerated (EXONERATED)
  • 11: Corrected (CORRECTED)
  • 12: Partially Corrected (PARTIALLY_CORRECTED)
  • 13: Uncorrected (UNCORRECTED)
  • 14: Delayed (DELAYED)
  • 15: Detected (DETECTED)
  • 16: No Action (NO_ACTION)
  • 17: Logged (LOGGED)
  • 18: Tagged (TAGGED)
  • 19: Alert (ALERT)
  • 20: Count (COUNT)
  • 21: Reset (RESET)
  • 22: Captcha (CAPTCHA)
  • 23: Challenge (CHALLENGE)
  • 24: Access Revoked (ACCESS_REVOKED)
  • 25: Rejected (REJECTED)
  • 26: Unauthorized (UNAUTHORIZED)
  • 27: Error (ERROR)
  • 99: Other (OTHER)
Destination Endpointdst_endpointNetwork Endpoint[]Entity:ENDPOINT
Group:primary

The responder (server) in a network connection.
Duration MillisecondsdurationLongGroup:occurrence

The event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds.
End Timeend_timeTimestampGroup:occurrence

The end time of a time period, or the time of the most recent event included in the aggregate event.
EnrichmentsenrichmentsEnrichment[]Group:context

The additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:["name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": "city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"]
Firewall Rulefirewall_ruleFirewall Rule[]Group:primary

The firewall rule that pertains to the control that triggered the event, if applicable.
Alertis_alertBooleanGroup:primary

Indicates that the event is considered to be an alertable signal. Should be set to true if disposition_id = Alert among other dispositions, and/or risk_level_id or severity_id of the event is elevated. Not all control events will be alertable, for example if disposition_id = Exonerated or disposition_id = Allowed.
JA4+ Fingerprintsja4_fingerprint_listJA4+ Fingerprint[]Group:context

A list of the JA4+ network fingerprints.
Load Balancerload_balancerLoad Balancer[]Group:primary

The Load Balancer object contains information related to the device that is distributing incoming traffic to specified destinations.
MalwaremalwareMalware[]Group:primary

A list of Malware objects, describing details about the identified malware.
Malware Scan Infomalware_scan_infoMalware Scan Info[]Group:primary

Describes details about the scan job that identified malware on the target system.
MessagemessageStringGroup:primary

The description of the event/finding, as defined by the source.
MetadatametadataMetadata[]Group:context

The metadata associated with the event or a finding.
ObservablesobservablesObservable[]Group:primary

The observables associated with the event or a finding.
OSINTosintOSINT[]Group:primary

The OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers.
PolicypolicyPolicy[]Group:primary

The policy that pertains to the control that triggered the event, if applicable. For example the name of an anti-malware policy or an access control policy.
PrecisionprecisionIntegerGroup:primary

The NTP precision quantifies a clock's accuracy and stability in log2 seconds, as defined in RFC-5905.
ProxyproxyNetwork Proxy Endpoint[]Entity:ENDPOINT
Group:primary

The proxy (server) in a network connection.

🚧 WARNING: DEPRECATED

Proxy has been deprecated since 1.1.0. Use the proxy_endpoint attribute instead.

Proxy Connection Infoproxy_connection_infoNetwork Connection Information[]Group:context

The connection information from the proxy server to the remote server.
Proxy Endpointproxy_endpointNetwork Proxy Endpoint[]Entity:ENDPOINT
Group:context

The proxy (server) in a network connection.
Proxy HTTP Requestproxy_http_requestHTTP Request[]Group:context

The HTTP Request from the proxy server to the remote server.
Proxy HTTP Responseproxy_http_responseHTTP Response[]Group:context

The HTTP Response from the remote server to the proxy server.
Proxy TLSproxy_tlsTransport Layer Security (TLS)[]Group:context

The TLS protocol negotiated between the proxy server and the remote server.
Proxy Trafficproxy_trafficNetwork Traffic[]Group:context

The network traffic refers to the amount of data moving across a network, from proxy to remote server at a given point of time.
Raw Dataraw_dataJSONGroup:context

The event data as received from the event source.
Raw Data Hashraw_data_hashFingerprint[]Entity:FINGERPRINT
Group:context

The hash, which describes the content of the raw_data field.
Raw Data Sizeraw_data_sizeLongGroup:context

The size of the raw data which was transformed into an OCSF event, in bytes.
Record IDrecord_idStringGroup:primary

Unique idenifier for the event
Risk Detailsrisk_detailsStringGroup:primary

Describes the risk associated with the finding.
Risk Levelrisk_levelStringGroup:primary

The risk level, normalized to the caption of the risk_level_id value.
Risk Level IDrisk_level_idIntegerGroup:primary

The normalized risk level id.
  • 0: Info (INFO)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 4: Critical (CRITICAL)
  • 99: Other (OTHER)
Risk Scorerisk_scoreIntegerGroup:primary

The risk score as reported by the event source.
SeverityseverityStringGroup:classification

The event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source.
Severity IDseverity_idIntegerGroup:classification

The normalized identifier of the event/finding severity.The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
  • 0: Unknown (UNKNOWN)
  • 1: Informational (INFORMATIONAL)
  • 2: Low (LOW)
  • 3: Medium (MEDIUM)
  • 4: High (HIGH)
  • 5: Critical (CRITICAL)
  • 6: Fatal (FATAL)
  • 99: Other (OTHER)
Source Endpointsrc_endpointNetwork Endpoint[]Entity:ENDPOINT
Group:primary

The initiator (client) of the network connection.
Start Timestart_timeTimestampGroup:occurrence

The start time of a time period, or the time of the least recent event included in the aggregate event.
StatusstatusStringGroup:primary

The event status, normalized to the caption of the status_id value. In the case of 'Other', it is defined by the event source.
Status Codestatus_codeStringGroup:primary

The event status code, as reported by the event source.For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18.
Status Detailstatus_detailStringGroup:primary

The status detail contains additional information about the event/finding outcome.
Status IDstatus_idIntegerGroup:primary

The normalized identifier of the event status.
  • 0: Unknown (UNKNOWN)
  • 1: Success (SUCCESS)
  • 2: Failure (FAILURE)
  • 99: Other (OTHER)
StratumstratumStringGroup:primary

The stratum level of the NTP server's time source, normalized to the caption of the stratum_id value.
Stratum IDstratum_idIntegerGroup:primary

The normalized identifier of the stratum level, as defined in RFC-5905.
  • 0: Unknown (UNKNOWN)
  • 1: Primary Server (PRIMARY_SERVER)
  • 2: Secondary Server (SECONDARY_SERVER)
  • 16: Unsynchronized (UNSYNCHRONIZED)
  • 17: Reserved (RESERVED)
  • 99: Other (OTHER)
Event TimetimeTimestampGroup:occurrence

The normalized event occurrence time or the finding creation time.
Timezone Offsettimezone_offsetIntegerGroup:occurrence

The number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080.
TLStlsTransport Layer Security (TLS)[]Group:context

The Transport Layer Security (TLS) attributes.
TraffictrafficNetwork Traffic[]Group:primary

The network traffic refers to the amount of data moving across a network at a given point of time. Intended to be used alongside Network Connection.
Type Nametype_nameStringGroup:classification

The event/finding type name, as defined by the type_uid.
Type IDtype_uidLongGroup:classification

The event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
  • 401300: NTP Activity: Unknown (NTP_ACTIVITY_UNKNOWN)
  • 401301: NTP Activity: Symmetric Active Exchange (NTP_ACTIVITY_SYMMETRIC_ACTIVE_EXCHANGE)
  • 401302: NTP Activity: Symmetric Passive Response (NTP_ACTIVITY_SYMMETRIC_PASSIVE_RESPONSE)
  • 401303: NTP Activity: Client Synchronization (NTP_ACTIVITY_CLIENT_SYNCHRONIZATION)
  • 401304: NTP Activity: Server Response (NTP_ACTIVITY_SERVER_RESPONSE)
  • 401305: NTP Activity: Broadcast (NTP_ACTIVITY_BROADCAST)
  • 401306: NTP Activity: Control (NTP_ACTIVITY_CONTROL)
  • 401307: NTP Activity: Private Use Case (NTP_ACTIVITY_PRIVATE_USE_CASE)
  • 401399: NTP Activity: Other (NTP_ACTIVITY_OTHER)
UnmappedunmappedUnmapped[]Group:context

Data from the source that was not mapped into the schema.
VersionversionStringGroup:context

The version number of the NTP protocol.

Relationships

NTP Activity shown in context

Outbound Relationships

NTP Activity references the following objects and events in its attributes:

This page describes qdm-1.5.1+ocsf-1.6.0