Web Resource Access Activity

web_resource_access_activity

🚧 WARNING: DEPRECATED Web Resource Access Activity has been deprecated since 1.0.0. Use the Web Resources Activity class with the Security Control and/or Network Proxy profile instead.
Web Resource Access Activity events describe successful/failed attempts to access a web resource over HTTP.

Attributes

CaptionNameTypeDescription
ActionactionStringGroup:primary

The normalized caption of action_id.
Action IDaction_idIntegerGroup:primary

The action taken by a control or other policy-based system leading to an outcome or disposition. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
  • 0: Unknown (UNKNOWN)
  • 1: Allowed (ALLOWED)
  • 2: Denied (DENIED)
  • 3: Observed (OBSERVED)
  • 4: Modified (MODIFIED)
  • 99: Other (OTHER)
Activity IDactivity_idIntegerGroup:classification

The normalized identifier of the activity that triggered the event.
  • 1: Access Grant (ACCESS_GRANT)
  • 2: Access Deny (ACCESS_DENY)
  • 3: Access Revoke (ACCESS_REVOKE)
  • 4: Access Error (ACCESS_ERROR)
  • 0: Unknown (UNKNOWN)
  • 99: Other (OTHER)
Activityactivity_nameStringGroup:classification

The event activity name, as defined by the activity_id.
ActoractorActor[]Group:primary

The actor object describes details about the user/role/process that was the source of the activity. Note that this is not the threat actor of a campaign but may be part of a campaign.
API DetailsapiAPI[]Group:context

Describes details about a typical API (Application Programming Interface) call.
MITRE ATT&CK® and ATLAS™ DetailsattacksMITRE ATT&CK® & ATLAS™[]Group:primary

An array of MITRE ATT&CK® objects describing identified tactics, techniques & sub-techniques. The objects are compatible with MITRE ATLAS™ tactics, techniques & sub-techniques.
Authorization InformationauthorizationsAuthorization Result[]Group:primary

Provides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event.
Categorycategory_nameStringGroup:classification

The event category name, as defined by category_uid value: Application Activity.
Category IDcategory_uidIntegerGroup:classification

The category unique identifier of the event.
  • 6: Application Activity (APPLICATION_ACTIVITY)
Classclass_nameStringGroup:classification

The event class name, as defined by class_uid value: Web Resource Access Activity.
Class IDclass_uidIntegerGroup:classification

The unique identifier of a class. A class describes the attributes available in an event.
  • 6004: Web Resource Access Activity (WEB_RESOURCE_ACCESS_ACTIVITY)
CloudcloudCloud[]Group:primary

Describes details about the Cloud environment where the event was originally created or logged.
ConfidenceconfidenceStringGroup:primary

The confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source.
Confidence IDconfidence_idIntegerGroup:primary

The normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
  • 0: Unknown (UNKNOWN)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 99: Other (OTHER)
Confidence Scoreconfidence_scoreIntegerGroup:primary

The confidence score as reported by the event source.
CountcountIntegerGroup:occurrence

The number of times that events in the same logical group occurred during the event Start Time to End Time period.
DevicedeviceDevice[]Entity:ENDPOINT
Group:primary

An addressable device, computer system or host.
DispositiondispositionStringGroup:primary

The disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source.
Disposition IDdisposition_idIntegerGroup:primary

Describes the outcome or action taken by a security control, such as access control checks, malware detections or various types of policy violations.
  • 0: Unknown (UNKNOWN)
  • 1: Allowed (ALLOWED)
  • 2: Blocked (BLOCKED)
  • 3: Quarantined (QUARANTINED)
  • 4: Isolated (ISOLATED)
  • 5: Deleted (DELETED)
  • 6: Dropped (DROPPED)
  • 7: Custom Action (CUSTOM_ACTION)
  • 8: Approved (APPROVED)
  • 9: Restored (RESTORED)
  • 10: Exonerated (EXONERATED)
  • 11: Corrected (CORRECTED)
  • 12: Partially Corrected (PARTIALLY_CORRECTED)
  • 13: Uncorrected (UNCORRECTED)
  • 14: Delayed (DELAYED)
  • 15: Detected (DETECTED)
  • 16: No Action (NO_ACTION)
  • 17: Logged (LOGGED)
  • 18: Tagged (TAGGED)
  • 19: Alert (ALERT)
  • 20: Count (COUNT)
  • 21: Reset (RESET)
  • 22: Captcha (CAPTCHA)
  • 23: Challenge (CHALLENGE)
  • 24: Access Revoked (ACCESS_REVOKED)
  • 25: Rejected (REJECTED)
  • 26: Unauthorized (UNAUTHORIZED)
  • 27: Error (ERROR)
  • 99: Other (OTHER)
Duration MillisecondsdurationLongGroup:occurrence

The event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds.
End Timeend_timeTimestampGroup:occurrence

The end time of a time period, or the time of the most recent event included in the aggregate event.
EnrichmentsenrichmentsEnrichment[]Group:context

The additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:["name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": "city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"]
Firewall Rulefirewall_ruleFirewall Rule[]Group:primary

The firewall rule that pertains to the control that triggered the event, if applicable.
HTTP Requesthttp_requestHTTP Request[]Group:context

Details about the underlying HTTP request.
HTTP Responsehttp_responseHTTP Response[]Group:context

Details about the HTTP response, if available.
Alertis_alertBooleanGroup:primary

Indicates that the event is considered to be an alertable signal. Should be set to true if disposition_id = Alert among other dispositions, and/or risk_level_id or severity_id of the event is elevated. Not all control events will be alertable, for example if disposition_id = Exonerated or disposition_id = Allowed.
MalwaremalwareMalware[]Group:primary

A list of Malware objects, describing details about the identified malware.
Malware Scan Infomalware_scan_infoMalware Scan Info[]Group:primary

Describes details about the scan job that identified malware on the target system.
MessagemessageStringGroup:primary

The description of the event/finding, as defined by the source.
MetadatametadataMetadata[]Group:context

The metadata associated with the event or a finding.
ObservablesobservablesObservable[]Group:primary

The observables associated with the event or a finding.
OSINTosintOSINT[]Group:primary

The OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers.
PolicypolicyPolicy[]Group:primary

The policy that pertains to the control that triggered the event, if applicable. For example the name of an anti-malware policy or an access control policy.
ProxyproxyNetwork Proxy Endpoint[]Entity:ENDPOINT
Group:context

Details about the proxy service, if available.

🚧 WARNING: DEPRECATED

Proxy has been deprecated since 1.1.0. Use the proxy_endpoint attribute instead.

Proxy Connection Infoproxy_connection_infoNetwork Connection Information[]Group:context

The connection information from the proxy server to the remote server.
Proxy Endpointproxy_endpointNetwork Proxy Endpoint[]Entity:ENDPOINT
Group:context

The proxy (server) in a network connection.
Proxy HTTP Requestproxy_http_requestHTTP Request[]Group:context

The HTTP Request from the proxy server to the remote server.
Proxy HTTP Responseproxy_http_responseHTTP Response[]Group:context

The HTTP Response from the remote server to the proxy server.
Proxy TLSproxy_tlsTransport Layer Security (TLS)[]Group:context

The TLS protocol negotiated between the proxy server and the remote server.
Proxy Trafficproxy_trafficNetwork Traffic[]Group:context

The network traffic refers to the amount of data moving across a network, from proxy to remote server at a given point of time.
Raw Dataraw_dataJSONGroup:context

The event data as received from the event source.
Raw Data Hashraw_data_hashFingerprint[]Entity:FINGERPRINT
Group:context

The hash, which describes the content of the raw_data field.
Raw Data Sizeraw_data_sizeLongGroup:context

The size of the raw data which was transformed into an OCSF event, in bytes.
Record IDrecord_idStringGroup:primary

Unique idenifier for the event
Risk Detailsrisk_detailsStringGroup:primary

Describes the risk associated with the finding.
Risk Levelrisk_levelStringGroup:primary

The risk level, normalized to the caption of the risk_level_id value.
Risk Level IDrisk_level_idIntegerGroup:primary

The normalized risk level id.
  • 0: Info (INFO)
  • 1: Low (LOW)
  • 2: Medium (MEDIUM)
  • 3: High (HIGH)
  • 4: Critical (CRITICAL)
  • 99: Other (OTHER)
Risk Scorerisk_scoreIntegerGroup:primary

The risk score as reported by the event source.
SeverityseverityStringGroup:classification

The event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source.
Severity IDseverity_idIntegerGroup:classification

The normalized identifier of the event/finding severity.The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
  • 0: Unknown (UNKNOWN)
  • 1: Informational (INFORMATIONAL)
  • 2: Low (LOW)
  • 3: Medium (MEDIUM)
  • 4: High (HIGH)
  • 5: Critical (CRITICAL)
  • 6: Fatal (FATAL)
  • 99: Other (OTHER)
Source Endpointsrc_endpointNetwork Endpoint[]Entity:ENDPOINT
Group:primary

Details about the source endpoint of the request.
Start Timestart_timeTimestampGroup:occurrence

The start time of a time period, or the time of the least recent event included in the aggregate event.
StatusstatusStringGroup:primary

The event status, normalized to the caption of the status_id value. In the case of 'Other', it is defined by the event source.
Status Codestatus_codeStringGroup:primary

The event status code, as reported by the event source.For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18.
Status Detailstatus_detailStringGroup:primary

The status detail contains additional information about the event/finding outcome.
Status IDstatus_idIntegerGroup:primary

The normalized identifier of the event status.
  • 0: Unknown (UNKNOWN)
  • 1: Success (SUCCESS)
  • 2: Failure (FAILURE)
  • 99: Other (OTHER)
Event TimetimeTimestampGroup:occurrence

The normalized event occurrence time or the finding creation time.
Timezone Offsettimezone_offsetIntegerGroup:occurrence

The number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080.
TLStlsTransport Layer Security (TLS)[]Group:context

The Transport Layer Security (TLS) attributes, if available.
Type Nametype_nameStringGroup:classification

The event/finding type name, as defined by the type_uid.
Type IDtype_uidLongGroup:classification

The event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
  • 600401: Web Resource Access Activity: Access Grant (WEB_RESOURCE_ACCESS_ACTIVITY_ACCESS_GRANT)
  • 600402: Web Resource Access Activity: Access Deny (WEB_RESOURCE_ACCESS_ACTIVITY_ACCESS_DENY)
  • 600403: Web Resource Access Activity: Access Revoke (WEB_RESOURCE_ACCESS_ACTIVITY_ACCESS_REVOKE)
  • 600404: Web Resource Access Activity: Access Error (WEB_RESOURCE_ACCESS_ACTIVITY_ACCESS_ERROR)
  • 600400: Web Resource Access Activity: Unknown (WEB_RESOURCE_ACCESS_ACTIVITY_UNKNOWN)
  • 600499: Web Resource Access Activity: Other (WEB_RESOURCE_ACCESS_ACTIVITY_OTHER)
UnmappedunmappedUnmapped[]Group:context

Data from the source that was not mapped into the schema.
Web Resourcesweb_resourcesWeb Resource[]Group:primary

Details about the resource that is the target of the activity.

Relationships

Web Resource Access Activity shown in context

Outbound Relationships

Web Resource Access Activity references the following objects and events in its attributes:

This page describes qdm-1.5.1+ocsf-1.6.0