Data Security Finding
data_security_finding
A Data Security Finding describes detections or alerts generated by various data security products such as Data Loss Prevention (DLP), Data Classification, Secrets Management, Digital Rights Management (DRM), Data Security Posture Management (DSPM), and similar tools. These detections or alerts can be created using fingerprinting, statistical analysis, machine learning or other methodologies. The finding describes the actors and endpoints who accessed or own the sensitive data, as well as the resources which store the sensitive data. Note: if the event producer is a security control, the security_control profile should be applied and its attacks information, if present, should be duplicated into the finding_info object. Note: If the Finding is an incident, i.e. requires incident workflow, also apply the incident profile or aggregate this finding into an Incident Finding.
Attributes
| Caption | Name | Type | Description |
|---|---|---|---|
| Action | action | String | Group:primaryThe normalized caption of action_id. |
| Action ID | action_id | Integer | Group:primaryThe action taken by a control or other policy-based system leading to an outcome or disposition. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
|
| Activity ID | activity_id | Integer | Group:classificationThe normalized identifier of the Data Security Finding activity.
|
| Activity | activity_name | String | Group:classificationThe Data Security finding activity name, as defined by the activity_id. |
| Actor | actor | Actor[] | Group:contextDescribes details about the actor implicated in the data security finding. Either an actor that owns a particular digital file or information store, or an actor which accessed classified or sensitive data. |
| API Details | api | API[] | Group:contextDescribes details about a typical API (Application Programming Interface) call. |
| Assignee | assignee | User[] | Entity:USERGroup: primaryThe details of the user assigned to an Incident. |
| Assignee Group | assignee_group | Group[] | Group:primaryThe details of the group assigned to an Incident. |
| MITRE ATT&CK® and ATLAS™ Details | attacks | MITRE ATT&CK® & ATLAS™[] | Group:primaryAn array of MITRE ATT&CK® objects describing identified tactics, techniques & sub-techniques. The objects are compatible with MITRE ATLAS™ tactics, techniques & sub-techniques. |
| Authorization Information | authorizations | Authorization Result[] | Group:primaryProvides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event. |
| Category | category_name | String | Group:classificationThe event category name, as defined by category_uid value: Findings. |
| Category ID | category_uid | Integer | Group:classificationThe category unique identifier of the event.
|
| Class | class_name | String | Group:classificationThe event class name, as defined by class_uid value: Data Security Finding. |
| Class ID | class_uid | Integer | Group:classificationThe unique identifier of a class. A class describes the attributes available in an event.
|
| Cloud | cloud | Cloud[] | Group:primaryDescribes details about the Cloud environment where the event was originally created or logged. |
| Comment | comment | String | Group:contextA user provided comment about the finding. |
| Confidence | confidence | String | Group:contextThe confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source. |
| Confidence ID | confidence_id | Integer | Group:contextThe normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
|
| Confidence Score | confidence_score | Integer | Group:contextThe confidence score as reported by the event source. |
| Count | count | Integer | Group:occurrenceThe number of times that events in the same logical group occurred during the event Start Time to End Time period. |
| Data Security | data_security | Data Security[] | Group:contextThe Data Security object describes the characteristics, techniques and content of a Data Loss Prevention (DLP), Data Loss Detection (DLD), Data Classification, or similar tools' finding, alert, or detection mechanism(s). |
| Database | database | Database[] | Group:primaryDescribes the database where classified or sensitive data is stored in, or was accessed from. Databases are typically datastore services that contain an organized collection of structured and/or semi-structured data. |
| Databucket | databucket | Databucket[] | Group:primaryDescribes the databucket where classified or sensitive data is stored in, or was accessed from. The data bucket object is a basic container that holds data, typically organized through the use of data partitions. |
| Device | device | Device[] | Entity:ENDPOINTGroup: contextDescribes the device where classified or sensitive data is stored in, or was accessed from. |
| Disposition | disposition | String | Group:primaryThe disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source. |
| Disposition ID | disposition_id | Integer | Group:primaryDescribes the outcome or action taken by a security control, such as access control checks, malware detections or various types of policy violations.
|
| Destination Endpoint | dst_endpoint | Network Endpoint[] | Entity:ENDPOINTGroup: contextDescribes the endpoint where classified or sensitive data is stored in, or was accessed from. |
| Duration Milliseconds | duration | Long | Group:occurrenceThe event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds. |
| End Time | end_time | Timestamp | Group:occurrenceThe time of the most recent event included in the finding. |
| Enrichments | enrichments | Enrichment[] | Group:contextThe additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:["name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": "city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"] |
| File | file | File[] | Entity:FILEGroup: primaryDescribes a file that contains classified or sensitive data. |
| Finding Information | finding_info | Finding Information[] | Group:primaryDescribes the supporting information about a generated finding. |
| Firewall Rule | firewall_rule | Firewall Rule[] | Group:primaryThe firewall rule that pertains to the control that triggered the event, if applicable. |
| Impact | impact | String | Group:contextThe impact , normalized to the caption of the impact_id value. In the case of 'Other', it is defined by the event source. |
| Impact ID | impact_id | Integer | Group:contextThe normalized impact of the incident or finding. Per NIST, this is the magnitude of harm that can be expected to result from the consequences of unauthorized disclosure, modification, destruction, or loss of information or information system availability.
|
| Impact Score | impact_score | Integer | Group:contextThe impact as an integer value of the finding, valid range 0-100. |
| Alert | is_alert | Boolean | Group:primaryIndicates that the event is considered to be an alertable signal. For example, an activity_id of 'Create' could constitute an alertable signal and the value would be true, while 'Close' likely would not and either omit the attribute or set its value to false. Note that other events with the security_control profile may also be deemed alertable signals and may also carry is_alert = true attributes. |
| Suspected Breach | is_suspected_breach | Boolean | Group:primaryA determination based on analytics as to whether a potential breach was found. |
| Malware | malware | Malware[] | Group:primaryA list of Malware objects, describing details about the identified malware. |
| Malware Scan Info | malware_scan_info | Malware Scan Info[] | Group:primaryDescribes details about the scan job that identified malware on the target system. |
| Message | message | String | Group:primaryThe description of the event/finding, as defined by the source. |
| Metadata | metadata | Metadata[] | Group:contextThe metadata associated with the event or a finding. |
| Observables | observables | Observable[] | Group:primaryThe observables associated with the event or a finding. |
| OSINT | osint | OSINT[] | Group:primaryThe OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers. |
| Policy | policy | Policy[] | Group:primaryThe policy that pertains to the control that triggered the event, if applicable. For example the name of an anti-malware policy or an access control policy. |
| Priority | priority | String | Group:primaryThe priority, normalized to the caption of the priority_id value. In the case of 'Other', it is defined by the event source. |
| Priority ID | priority_id | Integer | Group:primaryThe normalized priority. Priority identifies the relative importance of the incident or finding. It is a measurement of urgency.
|
| Raw Data | raw_data | JSON | Group:contextThe event data as received from the event source. |
| Raw Data Hash | raw_data_hash | Fingerprint[] | Entity:FINGERPRINTGroup: contextThe hash, which describes the content of the raw_data field. |
| Raw Data Size | raw_data_size | Long | Group:contextThe size of the raw data which was transformed into an OCSF event, in bytes. |
| Record ID | record_id | String | Group:primaryUnique idenifier for the event |
| Additional Resources | resources | Resource Details[] | Group:primaryDescribes details about additional resources, where classified or sensitive data is stored in, or was accessed from. You can populate this object, if the specific resource type objects available in the class (database, databucket, table, file) aren't sufficient; OR You can also choose to duplicate uid, name of the specific resources objects, for a consistent access to resource uids across all findings. |
| Risk Details | risk_details | String | Group:contextDescribes the risk associated with the finding. |
| Risk Level | risk_level | String | Group:contextThe risk level, normalized to the caption of the risk_level_id value. |
| Risk Level ID | risk_level_id | Integer | Group:contextThe normalized risk level id.
|
| Risk Score | risk_score | Integer | Group:contextThe risk score as reported by the event source. |
| Severity | severity | String | Group:classificationThe event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source. |
| Severity ID | severity_id | Integer | Group:classificationThe normalized identifier of the event/finding severity.The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
|
| Source Endpoint | src_endpoint | Network Endpoint[] | Entity:ENDPOINTGroup: contextDetails about the source endpoint where classified or sensitive data was accessed from. |
| Source URL | src_url | URL String | Entity:URL_STRINGGroup: primaryA Url link used to access the original incident. |
| Start Time | start_time | Timestamp | Group:occurrenceThe time of the least recent event included in the finding. |
| Status | status | String | Group:contextThe normalized status of the Finding set by the consumer normalized to the caption of the status_id value. In the case of 'Other', it is defined by the source. |
| Status Code | status_code | String | Group:primaryThe event status code, as reported by the event source.For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18. |
| Status Detail | status_detail | String | Group:primaryThe status detail contains additional information about the event/finding outcome. |
| Status ID | status_id | Integer | Group:contextThe normalized status identifier of the Finding, set by the consumer.
|
| Table | table | Table[] | Group:primaryDescribes the table where classified or sensitive data is stored in, or was accessed from. The table object represents a table within a structured relational database, warehouse, lake, or similar. |
| Ticket | ticket | Ticket[] | Group:primaryThe linked ticket in the ticketing system.
|
| Tickets | tickets | Ticket[] | Group:primaryThe associated ticket(s) in the ticketing system. Each ticket contains details like ticket ID, status, etc. |
| Event Time | time | Timestamp | Group:occurrenceThe normalized event occurrence time or the finding creation time. |
| Timezone Offset | timezone_offset | Integer | Group:occurrenceThe number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080. |
| Type Name | type_name | String | Group:classificationThe event/finding type name, as defined by the type_uid. |
| Type ID | type_uid | Long | Group:classificationThe event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
|
| Unmapped | unmapped | Unmapped[] | Group:contextData from the source that was not mapped into the schema. |
| Vendor Attributes | vendor_attributes | Vendor Attributes[] | Group:contextThe Vendor Attributes object can be used to represent values of attributes populated by the Vendor/Finding Provider. It can help distinguish between the vendor-provided values and consumer-updated values, of key attributes like severity_id.The original finding producer should not populate this object. It should be populated by consuming systems that support data mutability. |
| Verdict | verdict | String | Group:primaryThe verdict assigned to an Incident finding. |
| Verdict ID | verdict_id | Integer | Group:primaryThe normalized verdict of an Incident.
|
Relationships
Outbound Relationships
Data Security Finding references the following objects and events in its attributes:
- Group
- Unmapped
- Observable
- Finding Information
- Vendor Attributes
- Malware Scan Info
- Databucket
- Authorization Result
- Policy
- API
- Ticket
- Fingerprint
- Resource Details
- Database
- MITRE ATT&CK® & ATLAS™
- Network Endpoint
- Metadata
- Malware
- Cloud
- Table
- Enrichment
- Firewall Rule
- Actor
- File
- Data Security
- Device
- OSINT
- User
This page describes qdm-1.5.1+ocsf-1.6.0