Authentication
authentication
Authentication events report authentication session activities, including user attempts to log on or log off, regardless of success, as well as other key stages within the authentication process. These events are typically generated by authentication services, such as Kerberos, OIDC, or SAML, and may include information about the user, the authentication method used, and the status of the authentication attempt.
Attributes
| Caption | Name | Type | Description |
|---|---|---|---|
| Account Switch Type | account_switch_type | String | Group:primaryThe account switch method, normalized to the caption of the account_switch_type_id value. In the case of 'Other', it is defined by the event source. |
| Account Switch Type ID | account_switch_type_id | Integer | Group:primaryThe normalized identifier of the account switch method.
|
| Action | action | String | Group:primaryThe normalized caption of action_id. |
| Action ID | action_id | Integer | Group:primaryThe action taken by a control or other policy-based system leading to an outcome or disposition. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
|
| Activity ID | activity_id | Integer | Group:classificationThe normalized identifier of the activity that triggered the event.
|
| Activity | activity_name | String | Group:classificationThe event activity name, as defined by the activity_id. |
| Actor | actor | Actor[] | Group:contextThe actor object describes details about the user/role/process that was the source of the activity. Note that this is not the threat actor of a campaign but may be part of a campaign. |
| API Details | api | API[] | Group:contextDescribes details about a typical API (Application Programming Interface) call. |
| MITRE ATT&CK® and ATLAS™ Details | attacks | MITRE ATT&CK® & ATLAS™[] | Group:primaryAn array of MITRE ATT&CK® objects describing identified tactics, techniques & sub-techniques. The objects are compatible with MITRE ATLAS™ tactics, techniques & sub-techniques. |
| Authentication Factors | auth_factors | Authentication Factor[] | Group:contextDescribes a category of methods used for identity verification in an authentication attempt. |
| Auth Protocol | auth_protocol | String | Group:primaryThe authentication protocol as defined by the caption of auth_protocol_id. In the case of Other, it is defined by the event source. |
| Auth Protocol ID | auth_protocol_id | Integer | Group:primaryThe normalized identifier of the authentication protocol used to create the user session.
|
| Authentication Token | authentication_token | Authentication Token[] | Group:contextThe authentication token, ticket, or assertion, e.g. Kerberos, OIDC, SAML. |
| Authorization Information | authorizations | Authorization Result[] | Group:primaryProvides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event. |
| Category | category_name | String | Group:classificationThe event category name, as defined by category_uid value: Identity & Access Management. |
| Category ID | category_uid | Integer | Group:classificationThe category unique identifier of the event.
|
| Certificate | certificate | Digital Certificate[] | Group:primaryThe certificate associated with the authentication or pre-authentication (Kerberos). |
| Class | class_name | String | Group:classificationThe event class name, as defined by class_uid value: Authentication. |
| Class ID | class_uid | Integer | Group:classificationThe unique identifier of a class. A class describes the attributes available in an event.
|
| Cloud | cloud | Cloud[] | Group:primaryDescribes details about the Cloud environment where the event was originally created or logged. |
| Confidence | confidence | String | Group:primaryThe confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source. |
| Confidence ID | confidence_id | Integer | Group:primaryThe normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
|
| Confidence Score | confidence_score | Integer | Group:primaryThe confidence score as reported by the event source. |
| Count | count | Integer | Group:occurrenceThe number of times that events in the same logical group occurred during the event Start Time to End Time period. |
| Device | device | Device[] | Entity:ENDPOINTGroup: primaryAn addressable device, computer system or host. |
| Disposition | disposition | String | Group:primaryThe disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source. |
| Disposition ID | disposition_id | Integer | Group:primaryDescribes the outcome or action taken by a security control, such as access control checks, malware detections or various types of policy violations.
|
| Destination Endpoint | dst_endpoint | Network Endpoint[] | Entity:ENDPOINTGroup: primaryThe endpoint to which the authentication was targeted. |
| Duration Milliseconds | duration | Long | Group:occurrenceThe event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds. |
| End Time | end_time | Timestamp | Group:occurrenceThe end time of a time period, or the time of the most recent event included in the aggregate event. |
| Enrichments | enrichments | Enrichment[] | Group:contextThe additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:["name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": "city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"] |
| Firewall Rule | firewall_rule | Firewall Rule[] | Group:primaryThe firewall rule that pertains to the control that triggered the event, if applicable. |
| HTTP Request | http_request | HTTP Request[] | Group:contextDetails about the underlying HTTP request. |
| HTTP Response | http_response | HTTP Response[] | Group:contextDetails about the underlying HTTP response. |
| Alert | is_alert | Boolean | Group:primaryIndicates that the event is considered to be an alertable signal. Should be set to true if disposition_id = Alert among other dispositions, and/or risk_level_id or severity_id of the event is elevated. Not all control events will be alertable, for example if disposition_id = Exonerated or disposition_id = Allowed. |
| Cleartext Credentials | is_cleartext | Boolean | Group:contextIndicates whether the credentials were passed in clear text.Note: True if the credentials were passed in a clear text protocol such as FTP or TELNET, or if Windows detected that a user's logon password was passed to the authentication package in clear text. |
| Multi Factor Authentication | is_mfa | Boolean | Group:primaryIndicates whether Multi Factor Authentication was used during authentication. |
| New Logon | is_new_logon | Boolean | Group:contextIndicates logon is from a device not seen before or a first time account logon. |
| Remote | is_remote | Boolean | Group:primaryThe attempted authentication is over a remote connection. |
| Logon Process | logon_process | Linux Process[] | Entity:LINUX_PROCESSGroup: contextThe trusted process that validated the authentication credentials. |
| Logon Type | logon_type | String | Group:primaryThe logon type, normalized to the caption of the logon_type_id value. In the case of 'Other', it is defined by the event source. |
| Logon Type ID | logon_type_id | Integer | Group:primaryThe normalized logon type identifier.
|
| Malware | malware | Malware[] | Group:primaryA list of Malware objects, describing details about the identified malware. |
| Malware Scan Info | malware_scan_info | Malware Scan Info[] | Group:primaryDescribes details about the scan job that identified malware on the target system. |
| Message | message | String | Group:primaryThe description of the event/finding, as defined by the source. |
| Metadata | metadata | Metadata[] | Group:contextThe metadata associated with the event or a finding. |
| Observables | observables | Observable[] | Group:primaryThe observables associated with the event or a finding. |
| OSINT | osint | OSINT[] | Group:primaryThe OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers. |
| Policy | policy | Policy[] | Group:primaryThe policy that pertains to the control that triggered the event, if applicable. For example the name of an anti-malware policy or an access control policy. |
| Raw Data | raw_data | JSON | Group:contextThe event data as received from the event source. |
| Raw Data Hash | raw_data_hash | Fingerprint[] | Entity:FINGERPRINTGroup: contextThe hash, which describes the content of the raw_data field. |
| Raw Data Size | raw_data_size | Long | Group:contextThe size of the raw data which was transformed into an OCSF event, in bytes. |
| Record ID | record_id | String | Group:primaryUnique idenifier for the event |
| Risk Details | risk_details | String | Group:primaryDescribes the risk associated with the finding. |
| Risk Level | risk_level | String | Group:primaryThe risk level, normalized to the caption of the risk_level_id value. |
| Risk Level ID | risk_level_id | Integer | Group:primaryThe normalized risk level id.
|
| Risk Score | risk_score | Integer | Group:primaryThe risk score as reported by the event source. |
| Service | service | Service[] | Group:primaryThe service or gateway to which the user or process is being authenticated |
| Session | session | Session[] | Group:primaryThe authenticated user or service session. |
| Severity | severity | String | Group:classificationThe event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source. |
| Severity ID | severity_id | Integer | Group:classificationThe normalized identifier of the event/finding severity.The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
|
| Source Endpoint | src_endpoint | Network Endpoint[] | Entity:ENDPOINTGroup: primaryDetails about the source of the IAM activity. |
| Start Time | start_time | Timestamp | Group:occurrenceThe start time of a time period, or the time of the least recent event included in the aggregate event. |
| Status | status | String | Group:primaryThe event status, normalized to the caption of the status_id value. In the case of 'Other', it is defined by the event source. |
| Status Code | status_code | String | Group:primaryThe event status code, as reported by the event source.For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18. |
| Status Detail | status_detail | String | Group:primaryThe details about the authentication request. For example, possible details for Windows logon or logoff events are:SuccessLOGOFF_USER_INITIATEDLOGOFF_OTHERFailureUSER_DOES_NOT_EXISTINVALID_CREDENTIALSACCOUNT_DISABLEDACCOUNT_LOCKED_OUTPASSWORD_EXPIRED |
| Status ID | status_id | Integer | Group:primaryThe normalized identifier of the event status.
|
| Event Time | time | Timestamp | Group:occurrenceThe normalized event occurrence time or the finding creation time. |
| Timezone Offset | timezone_offset | Integer | Group:occurrenceThe number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080. |
| Type Name | type_name | String | Group:classificationThe event/finding type name, as defined by the type_uid. |
| Type ID | type_uid | Long | Group:classificationThe event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
|
| Unmapped | unmapped | Unmapped[] | Group:contextData from the source that was not mapped into the schema. |
| User | user | User[] | Entity:USERGroup: primaryThe subject (user/role or account) to authenticate. |
Relationships
Outbound Relationships
Authentication references the following objects and events in its attributes:
- User
- OSINT
- API
- Service
- Authentication Token
- Unmapped
- Observable
- HTTP Response
- MITRE ATT&CK® & ATLAS™
- Linux Process
- Enrichment
- Network Endpoint
- Policy
- Fingerprint
- Firewall Rule
- Digital Certificate
- HTTP Request
- Authorization Result
- Metadata
- Malware Scan Info
- Actor
- Authentication Factor
- Session
- Device
- Cloud
- Malware
This page describes qdm-1.5.1+ocsf-1.6.0